Skip to main content

Google Chrome v42 Compatibility Issues

Posted Date: 21 Apr 2015

Modified Date: 22 Apr 2015

Effective Date: 21 Apr 2015

Users who have upgraded to Chrome v42 may experience issues when accessing some University systems and services.

Last week, as part of the new Chrome v42 release, Google has disabled the NPAPI (Netscape Plugin Application Programming Interface) used by a number of popular plugins, including Java and Silverlight.

As a result of this change, users who have upgraded to the new browser version will be unable to access the University systems and services that support such plugins.

University Systems Affected

The most commonly used University systems affected by this change are listed below.

This is not a comprehensive list. The omission of a system from this list does not mean it is unaffected. If you have questions please contact the IT Support Center.

End User Impact

Users who have upgraded to Chrome v42 and are experiencing issues accessing a University system or service should switch to a different browser such as, Firefox, Safari, or Internet Explorer.

Kronos users who are unable to use Internet Explorer or Firefox and need to use Chrome will need to access Kronos using the the non-Java login link -  https://www-kronos.itcs.northwestern.edu/wfc/applications/wtk/html/ess/logon.jsp.

Additional Information:
Back to top