Skip to main content

GlobalProtect Upgrade Coming in October

Posted Date: 7 Oct 2021

Modified Date: 18 Oct 2021

Effective Date: 7 Oct 2021

Update - October 18, 2021: On October 13, Northwestern IT’s VPN vendor identified a critical vulnerability in the current versions of GlobalProtect. Due to this issue, users who upgraded before October 13 will receive a new request to upgrade to the latest version of GlobalProtect beginning Tuesday, October 19. Northwestern IT thanks everyone that took the initiative to self-upgrade last week and apologizes for the inconvenience of having to upgrade again. However, this is an important upgrade to maintain the security of users' devices and the Northwestern network.


Northwestern IT is performing an upgrade to GlobalProtect, the University’s Virtual Private Network (VPN), in October. The upgrade addresses security vulnerabilities in GlobalProtect and aligns Northwestern with the vendor’s upgrade window recommendations.

Users will have the ability to self-upgrade starting Tuesday, October 12, at 7:30 a.m. On this date, users will be prompted to upgrade GlobalProtect upon logging into a VPN-required service. Northwestern IT encourages users to complete the upgrade as soon as possible. Once initiated, the upgrade process takes a few minutes to complete. Please be aware the process will disconnect any in-use VPN sessions, and users will need to reconnect once the upgrade completes.

What to Expect

Please note, on Tuesday, October 26, at 7:30 a.m., the upgrade process becomes mandatory, as GlobalProtect will require all users to download and install the new client the next time a VPN connection is made. 

Anyone experiencing an issue with the GlobalProtect upgrade can contact the Northwestern IT Service Desk at consultant@northwestern.edu or 847-491-4357 (1-HELP).

Back to top